Actualizar BackTrack 5 R1 a Backtrack 5 R2 sin reinstalar


Hace poco salió la segunda revisión de BackTrack 5 que resuelve una gran cantidad de errores, añadía herramientas nuevas y actualizaba las herramientas con las que ya contábamos, al igual que hicimos con cuando salió la R1 de BackTrack 5 con el articulo “Actualizar BackTrack 5 a Backtrack 5 R1 sin reinstalar“, este articulo pretende dar una solución a la duda de todas estas personas nos han contactado por diferentes medios sobre como actualizar su versión de Backtrack sin reinstalar.

BT5R20 Actualizar BackTrack 5 R1 a Backtrack 5 R2 sin reinstalar

Para actualizar BackTrack 5 a Backtrack 5 R2 sin reinstalar, solo debemos realizar los siguientes pasos:

Actualizar nuestra distribución haciendo uso del administrador de paquetes apt

apt-get update

apt-get dist-upgrade

apt-get install beef

reboot

Debemos verificar que contemos con la versión 3.2.6 del kernel, revisando el resultado que arroje el comando

uname -a

En esta revisión 2 de BackTrack 5, se añadieron nuevas herramientas, por tanto debemos instalarlas usando el siguiente comando

apt-get install pipal findmyhash metasploit joomscan hashcat-gui golismero easy-creds pyrit sqlsus vega libhijack tlssled hash-identifier wol-e dirb reaver wce sslyze magictree nipper-ng rec-studio hotpatch xspy arduino rebind horst watobo patator thc-ssl-dos redfang findmyhash killerbee goofile bt-audit bluelog extundelete se-toolkit casefile sucrack dpscan dnschef

Por ultimo agregamos los nuevos repositorios de actualizaciones de seguridad a /etc/apt/sources.list, y ejecutamos otra actualización:

echo “deb http://updates.repository.backtrack-linux.org revolution main microverse non-free testing” >> /etc/apt/sources.list

apt-get update

apt-get dist-upgrade

Durante la actualización nos preguntaran sobre el archivo de revisión de actualizaciones. Nos debemos asegurar de mantener siempre el archivo de instalación en local. Para esto pulsamos “Enter” y aceptar todos los valores predeterminados.

BT5R2 Actualizar BackTrack 5 R1 a Backtrack 5 R2 sin reinstalar

BT5R2 1 Actualizar BackTrack 5 R1 a Backtrack 5 R2 sin reinstalar
Al reinstalar algunos servicios quedaran de nuevo al iniciar el sistema, si deseamos eliminarlos del inicio, simplemente los detenemos y los eliminamos del rc.d

/etc/init.d/apache2 stop

/etc/init.d/cups stop

/etc/init.d/winbind stop

update-rc.d -f cups remove

update-rc.d -f apache2 remove

update-rc.d -f winbind remove

Espero que te sirva para actualizar tu Backtrack 5 R1 a 5 R2 sin reinstalar por completo el sistema.


Si te ha gustado el post, compartelo y ayudanos a crecer.

Unete a nuestra Fanpage Siguenos en Twitter

Autor: DragoN

Ingeniero en Sistemas y Telecomunicaciones de la Universidad de Manizales. Information Security Researcher con más de 10 años de experiencias en Ethical Hacking, Pen Testing y Análisis Forense. Docente Universitario en Pre y Post-Grado, Speaker y Organizador de diferentes eventos de Seguridad Informática, Co-Fundador del ACK Security Conference y Fundador de DragonJAR SAS y de La Comunidad DragonJAR, una de las comunidades de seguridad informática mas grandes de habla hispana y referente en el sector.

Compartir este Artículo
  • http://SitioWeb(opcional) gaston

    bueno soy el primero :-D execelente tuto y muy buena explicacion…..claro yo ya estoy actualizando.gracias a todos por ser las personas que son si no esta comunidad no existiria.

  • Gabriel

    Oye probe los comandos y ya usar los repositorios y me lanza este error:

    #apt-get update
    E: Tipo ‘“deb’ desconocido en la línea 11 de lista de fuentes /etc/apt/sources.list

    y ya no puedo actualizar nada, me podeis ayudar!!

    • Gabriel

      NA… RESUELTO

      • Apr3ndiz

        1)amigo copia esto en el terminal :
        nano /etc/apt/sources.list
        2) copia lo que hay ahi aqui mismo .

        me da la impresión que agregaste mal un repositorio :)
        saludos me hechare una vuelta para ver si copiaste lo que te dije :) y asi tratar de ayudarte
        saludos

        • Gabriel

          si lo resolvi, el problema son las comillas del repositorio, no deben de ir
          por eso lanza el error

  • http://SitioWeb(opcional) gaston

    perdon mi novatez pero ste comando me esta matando el cerebro…
    root@bt:~# echo “deb http://updates repository.backtrack-linux.org revolution main microverse non-free testing” >> /etc/apt/sources.list
    me tira ese error……….
    E: Tipo ‘http://updates repository.backtrack-linux.org revolution main microverse’ desconocido en la línea 1 de lista de fuentes /etc/apt/sources.list
    algun alma caritativa que me de una mano???

  • http://SitioWeb(opcional) xexu

    hola a a todos yo tengo un problema yo tengo instalado backtrack 5 r1 en pen drive de 8 gigas cuando ejecuto apt-get update y luego apt-get dist-upgrade me dice que no tengo espacio suficiente en el disco que puedo hacer?no creo que se llene el espacio dado qe acabo de instalar backtrack en el pen.

    saludos

  • http://SitioWeb(opcional) gaston

    gracias gracias por hacerme trabajar a cabeza …..ya encontre las solucion….ahora entiendo por que todo el mundo adora al falso dios(osea 7)
    por que lo imposible esta en la mente de los comodos

    • Apr3ndiz

      que bueno que allas solucionado tu problema .

    • Gabriel

      si el problema son las comillas cuando agregas el repositorio.. :)

      • c10

        Podrias escribir como queda el comando corregido?

        • Apr3ndiz

          si tienes ese problema solo quitale las comillas al repositorio agregado fijate copia esto en el terminal:
          nano /etc/apt/sources.list

          y si ves algun repositorio con “comillas” pues dale quitale las comillas .

  • Sheyk87

    Buen dia, es GENIAL el tuto! Muchas gracias! Aguante Backtrack, lastima que se quedaron en el 9° video.
    Yo tengo un problema, lo uso en una notebook BGH, en una maquina virtual de VirtualBox, con Win 7 como nativo, pero no me toma el Wifi, estamos en red con la netbook de un amigo con XP, a traves de su red Wifi y anda para juegos y demas, pero al intentar rastrear la ip o la pc con BT en Armitage o otro, no lo ve, ni lo reconoce. Es porque BT no toma tarjetas WIFI?
    Con solo anfitrion anda bien, solo me pide un Pass para entrar las carpetas compartidas y lo raro es que mi Win7 no tiene Pass para nada, y si lo paso a puente, no anda. Con solo anfitrion encuentro a la anfitrion de la notebook, pero al pasarle armitage, ninguno de los sploits sirven para vulnerar el Win7. Que mal o que raro!

  • cepiyators

    jajajajaj….hice recontra mierda el disco
    en un momento no me alcanzo el tamaño de la particion quise extenderla desde win y ya no arranco mas…ni bt ni win ni ubuntu. supergrub no lo repara …asi que mis dias de hacerme el grande jugando con las pc han pasado

  • JL LOPEZ

    Me sirvio el post y no tuve que reinstalar todo.
    Gracias.. y buen post.

  • nano 2012

    esta renitido…full…

  • Gabriel

    Mes surgio otro problema: el sonido se escucha tanto en los auriculares como en las bocinas de la pc!!
    ya trate de repararlo pero no encuentro la solucion lo que hice fue esto pero aun no funciona:

    gedit /etc/modprobe.d/alsa-base
    options snd-hda-intel model=auto

    tambien instale alsamixerant pero no se soluciona….

    • Apr3ndiz

      ok que curioso problema , mira has esto , si esta pulseaudio en tu sistema desintalalo con
      apt-get remove pulseaudio y vuelvelo a instalar con apt-get install pulseaudio . pues ahora ejecuta pulseaudio y con ellos le das las configuraciones deseadas por ti para que no te suene en 2 partes no :)

  • elfilo

    Y q caracteristicas nuevas trae el R2… q cambios, q quitaron, q actualizaron y q hay nuevo?

  • cesar villamizar

    bueno… gracias

  • Irvin

    despues de esta instruccion echo “deb http://updates.repository.backtrack-linux.org revolution main microverse non-free testing” >> /etc/apt/sources.list

    le quiero dar apt-get update y ya no me deja actualizar me sale un error:

    E: Tipo ‘“deb’ desconocido en la línea 5 de lista de fuentes /etc/apt/sources.list

    :( como lo arreglo

    • http://www.dragonjar.org DragoN

      no copies y pegues, digita directamente o revisa el tipo de comillas con que se pegó el texto en tu equipo.

  • tron86

    Muchas gracias broo..!

  • aNdres

    esta tuanis el tuto, tengo un problema con la tarjeta wifi, cuando escribo el comando airmon-ng no me sale el nombre de mi interface, segun he leido es xq no detecta mi tarjeta, si tengo acceso a web, pero no me da el nombre de la interface, alguien que me pueda ayudar??

  • fercho

    Después de actualizar la versión r2 no me funcionan las carpetas compartidas, yo tengo el BT5 en una maquina virtual de VBOX en Ubuntu,

    La vaina rara es que tengo instaladas las guest aditions y aun asi cuando voy a compartir una carpeta me dice que estas no estan instaladas..
    a alguien mas le ha sucedido? alguien sabe cual puede ser la solución?

    Gracias

  • http://SitioWeb(opcional) niombre

    perdon pa ke sirve

    apt-get install beef
    busque en google y es como un inteprete de lenguajes o me ekivoco???

    es vital instalar eso????

  • http://SitioWeb(opcional) otro

    al ejecutar install pipal hasta dnschef me vota este error

    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    joomscan is already the newest version.
    magictree is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    easy-creds: Depends: ettercap but it is not going to be installed
    E: Broken packages

    a ke se debe???

  • http://www.accrochcode.com Elche

    Esta clarito, has un apt-get install de attercap……..
    Se instala y de ahi pruebas de nuevo con la linea anterior…. no funka por que hay una dependencia de paquete.

  • maxi

    hola, hice la actualizacion con los comando pero despues de uname -a me sigue Linux bt 2.6.38 #1 SMP Thu Mar 17 20:52:18 EDT 2011 i686 GNU/Linux, alguien me puede decir que estoy haciendo mal, desde ya muchas gracias!!!!